nix-config/shell.nix

14 lines
516 B
Nix

# Shell for bootstrapping flake-enabled nix and other tooling
{ pkgs ? let
lock =
(builtins.fromJSON (builtins.readFile ./flake.lock)).nodes.nixpkgs.locked;
nixpkgs = fetchTarball {
url = "https://github.com/nixos/nixpkgs/archive/${lock.rev}.tar.gz";
sha256 = lock.narHash;
};
in import nixpkgs { overlays = [ ]; }, ... }: {
default = pkgs.mkShell {
NIX_CONFIG = "extra-experimental-features = nix-command flakes";
nativeBuildInputs = with pkgs; [ home-manager git nh deploy-rs ];
};
}