18 lines
576 B
Nix
18 lines
576 B
Nix
# Configures programs that primarily run via the command line
|
|
{ pkgs, ... }: {
|
|
imports = [
|
|
./fish.nix # fish shell configuration
|
|
./lazygit.nix # my preferred git porcellain
|
|
./direnv.nix # smart cding
|
|
./helix.nix # helix configuration, my CLI editor
|
|
];
|
|
|
|
# stuff that doesn't fit into any other files
|
|
home.packages = with pkgs; [
|
|
ripgrep # well, it's grep
|
|
fastfetch # gotta show system information somehow!
|
|
flyctl # cli for a hosting service i use
|
|
httpie # good for inspecting APIs
|
|
exercism # cli for a great learning website!
|
|
];
|
|
}
|